<!DOCTYPE html><html><head><meta http-equiv="content-security-policy" content="default-src 'self'; connect-src 'self' https://*.keygen.sh https://ipinfo.io https://api.getrewardful.com; script-src 'self' https://keygen.sh https://aardwolf.keygen.sh https://r.wdfl.co https://cdn.getrewardful.com; style-src 'self' https://keygen.sh 'unsafe-inline'; font-src 'self' https://keygen.sh; img-src 'self' https://keygen.sh https://aardwolf.keygen.sh https://on-demand.bannerbear.com data:; object-src 'none'; base-uri 'none'; form-action 'self' https://app.keygen.sh;"><meta charset="UTF-8"><meta name="viewport" content="initial-scale=1"><meta name="referrer" content="no-referrer"><title>Good SaaS Products Are Like Unix Tools</title><meta name="description" content="Reusable, composable, single responsibility — these are all things good SaaS products have in common with Unix command line tools."><meta property="og:title" content="Good SaaS Products Are Like Unix Tools"><meta property="og:description" content="Reusable, composable, single responsibility — these are all things good SaaS products have in common with Unix command line tools."><meta property="og:image" content="https://on-demand.bannerbear.com/signedurl/nZ52rq9Ekxle3bp1Lj/image.jpg?modifications=W3sibmFtZSI6InRpdGxlIiwidGV4dCI6Ikdvb2QgU2FhUyBQcm9kdWN0cyBBcmUgTGlrZSBVbml4IFRvb2xzIn0seyJuYW1lIjoiZGVzYyIsInRleHQiOiJSZXVzYWJsZSwgY29tcG9zYWJsZSwgc2luZ2xlIHJlc3BvbnNpYmlsaXR5IOKAlCB0aGVzZSBhcmUgYWxsIHRoaW5ncyBnb29kIFNhYVMgcHJvZHVjdHMgaGF2ZSBpbiBjb21tb24gd2l0aCBVbml4IGNvbW1hbmQgbGluZSB0b29scy4ifSx7Im5hbWUiOiJsb2dvdHlwZSIsInRleHQiOiJrZXlnZW4uc2gvYmxvZyJ9XQ&amp;s=d4983aec23d37780b4a3475a3da586243d191a4ddf9a6ff81b5163737fccc5a9"><meta property="og:url" content="https://keygen.sh/blog/good-saas-products-are-like-unix-tools/"><meta property="og:site_name" content="Keygen"><meta property="og:type" content="website"><link rel="canonical" href="https://keygen.sh/blog/good-saas-products-are-like-unix-tools/"><link rel="shortcut icon" href="data:image/png;base64,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" type="image/x-icon"><link rel="icon" href="data:image/png;base64,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" sizes="64x64"><link rel="apple-touch-icon" href="/apple-touch-icon.png" sizes="180x180"><link rel="preload" href="/fonts/ubuntu-mono-400.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="/fonts/ubuntu-mono-700.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="/fonts/material-icons.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="/fonts/devicon.woff2" as="font" type="font/woff2" crossorigin><style>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</style></head><body><script src="/preload.js"></script><div class="container"><header class="header__wrapper"><div class="header"><div class="header__logo"><a class="logo" href="/"><canvas class="logo__logomark" width="64" height="64"></canvas><span class="logo__logotype effect--shuffle">Keygen</span></a></div><div class="header__nav"><nav class="navigation" id="nav"><div class="navigation__hamburger" id="nav-toggle"><i class="material-icons">menu</i></div><ul class="navigation__list"><li><span>Use Cases<i class="material-icons">expand_more</i></span><ul class="navigation__sublist navigation__sublist--wide"><li class="navigation__sublist__item"><a href="/software-licensing-api/"><i class="material-icons">lock_open</i> Software Application Licensing</a><small>Use Keygen's flagship software licensing API to add license key validation, device
activation and entitlements to any software product.
</small></li><li class="navigation__sublist__item"><a href="/software-distribution-api/"><i class="material-icons">cloud_download</i> Software Artifact Distribution</a><small>Use Keygen's supplementary software distribution API to securely deliver artifacts
and offer automatic updates to licensed users.
</small></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-on-prem-software/"><i class="devicon-aws"></i> For On-Premise/Multi-Prem
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-go-programs/"><i class="devicon-go"></i> For Go Programs
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-mac-apps/"><i class="devicon-macos"></i> For Mac Applications
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-docker-images/"><i class="devicon-docker"></i> For Container Images
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-windows-programs/"><i class="devicon-windows"></i> For Windows Programs
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-electron-apps/"><i class="devicon-electron"></i> For Electron Apps
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-wordpress-plugins/"><i class="devicon-wordpress"></i> For WordPress Plugins
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-wordpress-themes/"><i class="devicon-wordpress"></i> For WordPress Themes
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-python-packages/"><i class="devicon-python"></i> For Python Packages
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-composer-packages/"><i class="devicon-php"></i> For PHP Packages
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-npm-packages/"><i class="devicon-node"></i> For Node Packages
</a></li><li class="navigation__sublist__item navigation__sublist__item--grid"><a href="/for-rubygems/"><i class="devicon-ruby"></i> For Rubygems
</a></li></ul></li><li><span>Demos<i class="material-icons">expand_more</i></span><ul class="navigation__sublist"><li><a href="/demo/license-activation-portal/"><i class="material-icons">phonelink_lock</i> License Activation Portal Demo</a></li><li><a href="/demo/license-key-validation/"><i class="material-icons">vpn_key</i> License Key Validation Demo
</a></li></ul></li><li><span>Developers<i class="material-icons">expand_more</i></span><ul class="navigation__sublist"><li><a href="/docs/"><i class="material-icons">import_contacts</i> Developer Documentation</a></li><li><a href="/docs/api/"><i class="material-icons">code</i> API Reference</a></li><li><a href="/security/"><i class="material-icons">security</i> Security at Keygen</a></li><li><a href="/affiliates/"><i class="material-icons">favorite</i> Affiliate Program</a></li><li><a href="/changelog/"><i class="material-icons">update</i> Changelog</a></li><li><a href="/blog/"><i class="material-icons">article</i> Dev Blog</a></li><li><a href="/cdn-cgi/l/email-protection#fb888e8b8b94898fbb909e829c9e95d58893"><i class="material-icons">support</i> Get Support
</a></li></ul></li><li><a href="/build-vs-buy/">Build vs Buy
</a></li><li><a href="/pricing/">Pricing
</a></li><li><a href="https://app.keygen.sh/login">Log in
</a></li><li><a class="button button--secondary button--size-small" href="https://app.keygen.sh/register?plan=fba5986e-05d0-46e8-98cb-922a45887d4d">Sign Up</a></li></ul></nav></div></div></header><main class="main main--blog"><div class="main__title main__title--short" style="background-size: cover; background-position: center; background-image: linear-gradient(to bottom, rgba(0, 19, 49, 0.85), rgba(0, 19, 49, 0.75)), url('/images/its-a-unix-system.jpg');"><h1>Good SaaS Products Are Like Unix Tools</h1><p><small>Friday, November 12th 2021</small></p></div><div class="main__content__wrapper"><div class="main__content"><p>These days, SaaS (software-as-a-service) companies do too much. Very few focus in on a niche
market and ultimately stick to it. There&#39;s an obsession with growth, to every vertical possible,
in order to squeeze out as much revenue as possible. Or so it seems. If you take a step back,
out of Silicon Valley, into the land of small businesses, of bootstrappers, you&#39;ll find a Vast
Valley of sustainable micro-SaaS products.</p>
<p>So what&#39;s a micro-SaaS? I think it was a term coined by <a href="https://www.youtube.com/watch?v=i3d1asTrWUQ&amp;feature=emb_title">Tyler Tringas</a>,
but it&#39;s made a splash in <a href="https://userguiding.com/blog/micro-saas/">other parts of the web as well</a>.</p>
<hr>
<p>Here&#39;s how Tyler describes a micro-SaaS:</p>
<blockquote>
<p><em>“A SaaS business targeting a niche market, run by one person or a very small team, with
small costs, a narrow focus, a small but dedicated user base, and no outside funding.
Hence, micro-SaaS.”</em></p>
</blockquote>
<hr>
<p>I&#39;m not sure if Keygen is a micro-SaaS or not, but I like to think it is, and I think it fits with
my own mantra for business: find a niche, prioritize profitability and sustainability, and focus in
on <em>one thing</em> and <em>do that one thing well</em>.</p>
<p>The &quot;one thing&quot; part really reminds me of Unix tools, which (mostly) try to do one thing, and they
do it well. Reusable, composable, and of course, single responsibility. Staples like <code>less</code>,
<code>grep</code>, <code>cat</code>, <code>mv</code>, <code>cp</code>, and <code>sed</code>.</p>
<p>When a product does one thing well, it can become composable, just a Unix tool.</p>
<pre class="torchlight" style="background-color: #24292e; --theme-selection-background: #39414a;" data-torchlight-processed="3449c9e5e332f1dbb81505cd739fbf3f"><code class="lang-bash"><div class='line'><span style="color: #79B8FF;">echo</span><span style="color: #E1E4E8;"> </span><span style="color: #9ECBFF;">&#39;hello, world!&#39;</span><span style="color: #E1E4E8;"> </span><span style="color: #F97583;">&gt;</span><span style="color: #E1E4E8;"> </span><span style="color: #9ECBFF;">hello.txt</span><span style="color: #E1E4E8;"> &amp;&amp; </span><span style="color: #79B8FF;">\</span></div><div class='line'><span style="color: #E1E4E8;">  </span><span style="color: #B392F0;">cat</span><span style="color: #E1E4E8;"> </span><span style="color: #9ECBFF;">hello.txt</span><span style="color: #E1E4E8;"> </span><span style="color: #79B8FF;">\</span></div><div class='line'><span style="color: #E1E4E8;">    </span><span style="color: #F97583;">|</span><span style="color: #E1E4E8;"> </span><span style="color: #B392F0;">grep</span><span style="color: #E1E4E8;"> </span><span style="color: #79B8FF;">-i</span><span style="color: #E1E4E8;"> </span><span style="color: #9ECBFF;">&#39;world&#39;</span><span style="color: #E1E4E8;"> </span><span style="color: #79B8FF;">\</span></div><div class='line'><span style="color: #E1E4E8;">    </span><span style="color: #F97583;">|</span><span style="color: #E1E4E8;"> </span><span style="color: #B392F0;">sed</span><span style="color: #E1E4E8;"> </span><span style="color: #9ECBFF;">s/world/universe/</span><span style="color: #E1E4E8;"> </span><span style="color: #79B8FF;">\</span></div><div class='line'><span style="color: #E1E4E8;">    </span><span style="color: #F97583;">|</span><span style="color: #E1E4E8;"> </span><span style="color: #B392F0;">less</span></div><textarea data-torchlight-original="true" style="display: none !important;">echo 'hello, world!' &gt; hello.txt &amp;&amp; \
  cat hello.txt \
    | grep -i 'world' \
    | sed s/world/universe/ \
    | less
</textarea></code></pre>
<hr>
<blockquote>
<p><em>&quot;It’s a <del>Unix system</del> micro-SaaS. I know this.&quot;
— Jurassic Park, probably</em></p>
</blockquote>
<hr>
<p>As a real life example — people ask me quite often if Keygen handles billing.</p>
<p>The answer to that is &quot;no.&quot;</p>
<p>But not a &quot;no, you&#39;re out of luck&quot; kind of no, but a &quot;here&#39;s what we do, what we focus on, and here&#39;s how
you can integrate us with a payment provider.&quot;</p>
<p>But couldn&#39;t I just build out an out-of-the-box integration with say, Stripe, and call it a day? Add a
simple license checkout flow using Stripe&#39;s hosted stuff?</p>
<p>Not really.</p>
<p>Over the course of the nearly 6 years since I started Keygen, I&#39;ve had the opportunity of getting
visibility into how various companies handle billing. From small to large. And let me tell you —
they all do it differently. Especially when we&#39;re talking ISVs that have more than 10 employees,
which is the market I&#39;ve started to settle into.</p>
<p>If I were to create an official Stripe integration, or a Paddle or FastSpring integration, it&#39;d need
to be so complex and flexible that I&#39;d end up building an entirely new product on top of my main
product, just to handle the myriad of ways companies do billing, and how they initialize data within
Keygen during and after the purchasing flow.</p>
<p>And I still wouldn&#39;t be able to support every use case.</p>
<p>It&#39;s just not feasible for a micro-SaaS.</p>
<p>It&#39;s much easier to let companies compose our SaaS with others to fulfill their unique requirements.
They end up with <em>the perfect setup</em>, and I can do less.</p>
<p>Billing isn&#39;t my niche — licensing is. So there&#39;s a super simple reason Keygen doesn&#39;t handle
billing: <em>because it&#39;s not licensing.</em></p>
<p>I truly believe a lot founders try to make their products do way too much, especially when it comes to
first time technical founders. I mean, I see founders adding feature after feature onto their product,
some loosely related, before they even launch anything!</p>
<p>They end up throwing in the kitchen-sink, and they end up muddying their product offering as well as
segmenting their focus, which is bad for a micro-SaaS.</p>
<p>Like, really, really bad.</p>
<p>Stay focused.</p>
<p>Another example of something I don&#39;t do would be complex product analytics. I do the bare-minimum for
analytics, and it works for 90% of my customers. A handful of complex SQL queries and I called it a
day. I mean, over half of my customers don&#39;t even use the UI — they only use the API — so I can&#39;t
reasonably spend too much time here.</p>
<p>So the segment of customers that need better analytics go on to integrate with another SaaS, like Amplitude,
or one of the hundreds of other analytics-focused products. They do their one thing, I do mine. The
customer wins because they have products that focus on doing one thing well, instead of trying to do
everything but nothing well.</p>
<p>Like Tyler mentioned in his talk, there&#39;s a reason my customers, like his at the time, are more likely
to go out of business than to churn — because my micro-SaaS does one thing, and does it well. My focus
isn&#39;t split on tens of sub-products all doing different things. I&#39;m 100% focused on my one thing, so
my customers can be 100% focused on their thing.</p>
<p>Focusing on one thing has also helped form good relationships with a lot of these billing and analytics
companies, and I recommend business to them, and they recommend business to me. Businesses use us
together — they compose us — to accomplish their unique business requirements.</p>
<p>I let my customers choose how to best handle billing. It&#39;s not my focus.</p>
<p>Once you start throwing in the kitchen-sink, you start competing with all the other companies that have
also thrown in the kitchen-sink. You have to have feature parity to compete. And they&#39;re likely VC-backed,
which is probably why they offer it in the first place. Your business enters a constant state of new
product development.</p>
<p>As an owner of a bootstrapped SaaS, that just doesn&#39;t sound very sustainable.</p>
<p>You stretch yourself too thin, you&#39;ll likely fail.</p>
<hr>
<p>So, how do you build a composable SaaS? <em>By doing one thing.</em></p>
<p>Well, and <a href="/blog/how-to-build-a-webhook-system-in-rails-using-sidekiq/">webhooks</a>. Lots and lots of webhooks.</p>
<p>Webhooks are like the <code>|</code> operator of SaaS.</p>
<p>By using webhooks, SaaS products can be wired up to talk to any number of other SaaS products, asynchronously.
It&#39;s really quite amazing how pivotal webhooks have become in the infrastructure of the modern web. Webhooks
are something I didn&#39;t see a lot until Stripe, but I&#39;m sure there were others who came before.</p>
<p>Rather than build more and more onto my product, it&#39;s so much easier to hop on an email thread with engineering
and say &quot;here&#39;s what a webhook is, but you probably already know that, and here&#39;s how you can get your
billing system to talk to our licensing system.&quot;</p>
<p>They go from asking if and why we don&#39;t handle billing, to being excited about composing their favorite
tools together to accomplish their goals.</p>
<hr>
<p>To wrap up — your product doesn&#39;t have to do everything. There are other products that can do the things
that your product doesn&#39;t do.</p>
<p>Focus on one thing and you&#39;ll be surprised at how people compose your product with other products,
just like the Unix tools we love and use everyday.</p>
<p>Find a niche, narrow your focus, and do one thing well.</p>
<p>Until next time.</p>
<hr>
<p>Follow me on Twitter: <a href="https://twitter.com/ezekgabrielse">@ezekgabrielse</a></p>
</div></div></main></div><div class="footer__content">© 2016–2021 Keygen LLC – All Rights Reserved – Reach out &lt;<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="19717c75757659727c607e7c77376a71">[email&#160;protected]</a>&gt;
</div><ul class="footer__links"><li><a href="https://status.keygen.sh">Status</a></li><li><a href="/security/">Security</a></li><li><a href="/beginners-guide-to-software-licensing/glossary/">Glossary</a></li><li><a href="/changelog/">Changelog</a></li><li><a href="/privacy/">Privacy</a></li><li><a href="/terms/">Terms</a></li><li><a href="/terms/sla/">SLA</a></li><li><a href="/integrate/">Integrate</a></li><li><a href="/compare/">Compare</a></li><li><a href="/affiliates/">Affiliates</a></li><li><a href="/blog/">Blog</a></li><li><a href="/jobs/">Jobs</a></li><li><a href="https://github.com/keygen-sh" target="_blank" rel="noopener"><i class="devicon-github"></i></a></li><li><a href="https://twitter.com/keygen_sh" target="_blank" rel="noopener"><i class="devicon-twitter"></i></a></li></ul><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="/app.js"></script><script async data-site="XMLLXLCZ" src="https://aardwolf.keygen.sh/script.js"></script><script async data-rewardful="07d24b" src="https://r.wdfl.co/rw.js"></script><style>@charset "UTF-8";@font-face{font-family:Ubuntu;font-style:normal;font-weight:300;font-display:swap;src:url(https://keygen.sh/fonts/ubuntu-300.woff2) format("woff2")}@font-face{font-family:Ubuntu;font-style:italic;font-weight:300;font-display:swap;src:url(https://keygen.sh/fonts/ubuntu-300-italic.woff2) format("woff2")}@font-face{font-family:Ubuntu;font-style:normal;font-weight:400;font-display:swap;src:url(https://keygen.sh/fonts/ubuntu-400.woff2) format("woff2")}@font-face{font-family:Ubuntu;font-style:italic;font-weight:400;font-display:swap;src:url(https://keygen.sh/fonts/ubuntu-400-italic.woff2) format("woff2")}@font-face{font-family:Ubuntu;font-style:normal;font-weight:700;font-display:swap;src:url(https://keygen.sh/fonts/ubuntu-700.woff2) format("woff2")}@font-face{font-family:Ubuntu;font-style:italic;font-weight:700;font-display:swap;src:url(https://keygen.sh/fonts/ubuntu-700-italic.woff2) format("woff2")}@font-face{font-family:Ubuntu Mono;font-style:normal;font-weight:400;font-display:swap;src:url(https://keygen.sh/fonts/ubuntu-mono-400.woff2) format("woff2")}@font-face{font-family:Ubuntu Mono;font-style:normal;font-weight:700;font-display:swap;src:url(https://keygen.sh/fonts/ubuntu-mono-700.woff2) format("woff2")}@font-face{font-family:Material Icons;font-style:normal;font-weight:400;font-display:block;src:url(https://keygen.sh/fonts/material-icons.woff2) format("woff2")}.material-icons{font-family:Material Icons;font-weight:400;font-style:normal;font-size:24px;line-height:1;letter-spacing:normal;text-transform:none;display:inline-block;white-space:nowrap;word-wrap:normal;direction:ltr;-moz-font-feature-settings:"liga";-moz-osx-font-smoothing:grayscale}@font-face{font-family:Devicon;font-style:normal;font-weight:400;font-display:block;src:url(https://keygen.sh/fonts/devicon.woff2) format("woff2")}[class*=" devicon-"],[class^=devicon-]{font-family:Devicon!important;font-variant:normal;font-style:normal;font-weight:400;text-transform:none;line-height:1;speak:never;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale}.devicon-github:before{content:""}.devicon-twitter:before{content:""}.devicon-js:before,.devicon-node:before{content:""}.devicon-ruby:before{content:""}.devicon-docker:before{content:""}.devicon-electron:before{content:""}.devicon-python:before{content:""}.devicon-php:before{content:""}.devicon-rust:before{content:""}.devicon-go:before{content:""}.devicon-csharp:before{content:""}.devicon-bash:before{content:""}.devicon-cpp:before{content:""}.devicon-wordpress:before{content:""}.devicon-macos:before{content:""}.devicon-windows:before{content:""}.devicon-aws:before{content:""}
/*# sourceMappingURL=fonts.css.map */</style></body></html>